Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу...

0 голосов
50 просмотров

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.


Информатика (24 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Program zadacha;
   var   i,s:integer;
begin 
   read(s); 
   for i:=10 to 99 do begin   
      if(((i mod 10) + (i div 10)) = s) then        
            writeln(i); 
   end;
end.

(156 баллов)