Напишите программу в которой определяется сумма S всех целых чисел в интервале заданном...

0 голосов
43 просмотров

Напишите программу в которой определяется сумма S всех целых чисел в интервале заданном переменами N и M а так же сумма SA четных и SB нечетных в этомже интервале


Информатика | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Язык С#
код:
using System;namespace ConsoleApp95{    class Program    {        static void Main(string[] args)        {            int N, M,S = 0 ,SB = 0 ,SA = 0 ;            N = Convert.ToInt32(Console.ReadLine());            M = Convert.ToInt32(Console.ReadLine());            for ( int i = N+1; i < M; i++)            {                if ( i % 2 == 0 )                {                    S += i;                    SA += i;                }                else                {                    SB += i;                }            }            Console.WriteLine(S + "   " + SA + "  " + SB);            Console.ReadKey();        }    }}

(158 баллов)