Написать программу, которая n раз выводит ** экран слова : Привет, друг!

0 голосов
122 просмотров

Написать программу, которая n раз выводит на экран слова : Привет, друг!


Информатика (112 баллов) | 122 просмотров
0

язык программирования какой? paskal?

0

Да

0

Ниже код хороший

0

А можно поподробнее

0

Так достаточно подробно?

0

Спасибо

Дано ответов: 2
0 голосов

//Pascal
var
n, i: integer;
begin
write('Введите n: '); readln(n);
for i := 1 to n do
writeln('Привет, друг!');
readln;
end.

(9.4k баллов)
0

Зачем последний "readln;"? Без него норм

0

А, я же на АБС, у меня не сразу все вылетает)

0 голосов

//Pascal
var  //Объявление переменных
n, i: integer;  //Объявляем переменные n - количество повторов и i - счетчик для цикла
begin  //Открытие логических скобок
write('Введите n: ');  //Выводит текст на монитор 'Введите n: '
readln(n);  //запрашивает ввод с клавиатуры и заносит значение в переменную n
for i := 1 to n do  //Цикл от 1 до числа n
writeln('Привет, друг!');  //С каждым шагом цикла выводится сообщение 'Привет, друг!'
readln;  //ожидание нажатия Enther после выполнения программы
end.

(3.4k баллов)