Написать программу ** языке Pascal. Задание 1: Вводится название месяца. Вывести пору...

0 голосов
55 просмотров

Написать программу на языке Pascal. Задание 1: Вводится название месяца. Вывести пору года для этого месяца (январь - зима, …, март - весна, …, август - лето, …);
Задание 2: Вводиться пора года. Вывести названия месяцев для этой поры года.


Информатика (21 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s:string;

begin
readln(s);
case s of
'Январь','Декабрь','Февраль': writeln('Зима');         
'Март','Апрель','Май' : writeln('Весна');         
'Июнь','Июль','Август' : writeln('Лето');         
 'Сентябрь','Октябрь','Ноябрь' : writeln('Осень');         
'Зима' : writeln('Декабрь ','Январь ','Февраль');         
 'Весна' : writeln('Март ','Апрель ','Май');         
 'Лето' : writeln('Июнь ','Июль ','Август');         
'Осень' : writeln('Сентябрь ','Октябрь ','Ноябрь');
end;
end.            

(388 баллов)