Напишите программу ** паскале которая решает уравнение ax^2+bx+c=0 используя циклы

0 голосов
45 просмотров

Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы


Информатика (50 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Для Одри можно и покороче ))
Только для случая одного корня печатается 2 одинаковых. Так тоже можно

Var a,b,c,d: real;
Begin
WriteLn('Решение ax^2 + bx +c = 0');
WriteLn('Введите a b с '); ReadLn (a, b, c);
if a=0 then WriteLn('Это не квадратное уравнение. Решайте его сами! ')
else
begin
d:=b*b-4*a*c;
if d<0 then Writeln('Нет действительных корней') <br>else WriteLn('корни: ', (-b+Sqrt(d))/(2*a),' и ', (-b-Sqrt(d))/(2*a) );
end;
ReadLn
End.

(150 баллов)