Помогите составить программу в паскаль!!!!!

0 голосов
25 просмотров

Помогите составить программу в паскаль!!!!!


image

Информатика (41 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses crt;
var
  otvet: real; a,b,z12,z1,z2,x :integer;

begin
textcolor(random(2,15));
  write('Задача №: ');
  textcolor(random(1,15));
  readln(z12);
  if (z12<1) or (z12>2) then
  begin
  textcolor(4);
  writeln('Такой задачи нет!');
  textcolor(random(1,15));
  end;
  if z12=1 then
  b:=10;
  for a:=1 to b do
  begin
  otvet:=(sqrt(a)+sqr(a)*a)*a;
  textcolor(random(1,15));
  writeln(a,') ',otvet);
  end;
  if z12=2 then
  b:=40;
  for a:=0 to b do
  if (a mod 7=0) and (a>0) then
  begin
  textcolor(random(1,15));
  writeln(a,') ',a);
  end;
end.

(538 баллов)
0

Покажи это учителю он 5 поставит

0

Ну можно без ответа?

0

Всмысле???

0

Ну без этой надписи

0

Так это тоже самое что и за место otvet написать с или а или b

0

Это обычная переменая

0

var
c: real;
a, b: integer;

begin
b := 10;
for a := 1 to b do
begin
otvet := (sqrt(a) + sqr(a) * a) * a;
writeln(a, ') ', c);
end;
end.

0

Можно так

0

О, спасибо огромное!!!!!!!!!

0

otvet это была переменая как сейчас и "C"