Напишите программу, которая ** вход получает целое число и проверяет, есть ли в числе 2...

0 голосов
21 просмотров

Напишите программу, которая на вход получает целое число и проверяет, есть ли в числе 2 одинаковые цифры (pascal, с использованием циклов)


Информатика (180 баллов) | 21 просмотров
Дан 1 ответ
0 голосов

Var a: array[0..9] of integer;
    i,n,k: integer;
    pr: string;
begin
   pr:='нет';
   for i:=0 to 9 do a[i]:=0;
   write('число: ');  readln(n);
   repeat
     k:=n mod 10;
     a[k]:=a[k]+1;
     if a[k]>1 then
     begin
       pr:='есть';
       break;
     end;  
     n:=n div 10;
   until n=0;
   writeln(pr);
end.

ввод - вывод

число: 122456
есть

число: 12546
нет






(9.7k баллов)