.Напишите программу формирования и вывода массива размером 6x3, каждые три...

0 голосов
43 просмотров

.Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й — равен случайному двузначному числу; 2-й — равен целой части от деления случайного трехзначного числа на сумму индексов текущего элемента; 3-й — равен остатку от деления случайного двухзначного числа на 10.


Информатика (85 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

Program arrays;
var a:array [1..3,1..6] of integer;   
i,j:byte;
begin
for i:=1 to 3 do 
    for j:=0 to 1 do   
          begin   
                    a[i,1+3*j]:=random(101)+10;
                    a[i,2+3*j]:=random((1001)+100) div (i+2*j);
                    a[i,3+3*j]:=(random(101)+10) mod 10;   
           end; 
   for i:=1 to 3 do 
           begin 
                      for j:=1 to 6 do   
                                 write(a[i,j],'  '); 
                     writeln;   
         end;
 end.

//Если нужны пояснения - пишите

(696 баллов)