Напишите программу, находящую сумму 2 чисел, переданных в качестве входных данных....

0 голосов
79 просмотров

Напишите программу, находящую сумму 2 чисел, переданных в качестве входных данных. Входные данные: На стандартный ввод передаются два целых числа a,b (0≤a,b≤9)a,b (0≤a,b≤9) Выходные данные: Передайте на стандартный вывод одно число – сумму введенных чисел. Sample Input 1: 6 2 Sample Output 1: 8 Sample Input 2: 6 1 Sample Output 2: 7


Информатика (15 баллов) | 79 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main() {
    bool checkA = false;
    bool checkB = false;
    int a;
    int b;
    cin >> a >> b;
    cout << "Entered nums: \n";<br> cout << a << "\n";<br> cout << b << "\n";<br> if(a >= 0) {
    checkA = true;
    cout << a << " is >= 0 \n";
}
else {
    checkA = false;
    cout << a << " isn't >= 0 \n -Failed \n";
}
if(b <= 9) {<br>     checkB = true;
    cout << b << " is <= 9 \n";<br> }
else {
    checkB = false;
    cout << b << " isn't <= 9 \n -Failed \n";<br> }
if(checkA&&checkB == true) {
    int sum = a+b;
    cout << "Sum is " << sum;<br> }
else {
    cout << "\n Wrong nums";<br> }
}

(275 баллов)