Помогите плиз написать программу : Дан двумерный массив А, состоящий из N элементов....

0 голосов
31 просмотров

Помогите плиз написать программу :
Дан двумерный массив А, состоящий из N элементов. Найти минимальный из элементов этого массива с нечетными индексами и максимальный из элементов с четными индексами.


Информатика (146 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

Var
  a: array [1..100] of integer;

begin
  var N := ReadInteger;
  var mmax := Integer.MinValue;
  var mmin := integer.MaxValue;
  for var i := 1 to N do
  begin
    readln(a[i]);
    if (i mod 2 <> 0) and(a[i] < mmin) then mmin := a[i];
    if (i mod 2 = 0) and (a[i] > mmax) then mmax := a[i]
  end;
  writeln('Минимальный элемент массива с нечетным индексом: ', mmin);
  writeln('Максимальный элемент массива с четным индексом: ', mmax)
end.

(720 баллов)
0

Не работает

0

пишет : "Ошибка: ожидался идентификатор, но "var" обнаружено." через абц паскаль писал

0

попробуй обновить версию.

0

я писал на версии 3.3

0

var
a: array [1..100, 1..100] of integer;

begin
var N := ReadInteger;
var mmax := Integer.MinValue;
var mmin := integer.MaxValue;
for var j := 1 to N do
for var i := 1 to N do
begin
read(a[j, i]);
if (j mod 2 <> 0) and (i mod 2 <> 0) and (a[j, i] < mmin) then mmin := a[j, i];
if (j mod 2 = 0) and (i mod 2 = 0) and (a[j, i] > mmax) then mmax := a[j, i]
end;
writeln('Минимальный элемент массива с нечетным индексом: ', mmin);
writeln('Максимальный элемент массива с четным индексом: ', mmax)
end.

0

Пример:
Ввод:
3
1 2 3
4 5 6
7 8 9
Вывод:
Минимальный элемент массива с нечетным индексом: 1
Максимальный элемент массива с четным индексом: 5