Помогите пожалуйста) информатика PascalABC.NET 1)Составьте программу , которая выводит **...

0 голосов
28 просмотров

Помогите пожалуйста) информатика PascalABC.NET
1)Составьте программу , которая выводит на экран все двухзначные числа,сумма цифр которых делится на 7.
2)Составьте программу:с клавиатуры вводятся два натуральных числа x и y.
Вывести на экран все четные числа на отрезке [x,y] и подсчитать сумму этих чисел.


Информатика (25 баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3, сборка 1555 от 21.10.2017
Внимание! Если программа не работает, обновите версию!

№1

begin
  for var i:=10 to 99 do
    if (i div 10 + i mod 10) mod 7=0 then Print(i);
  Writeln
end.

Результат
16 25 34 43 52 59 61 68 70 77 86 95

№2

begin
  var (x,y):=ReadInteger2;
  Writeln('S=',x.To(y).Where(i->i.IsEven).Println.Sum)
end.

Пример
5 30
6 8 10 12 14 16 18 20 22 24 26 28 30
S=234
(150k баллов)