Составить программу F=1+2+..+N

0 голосов
32 просмотров

Составить программу
F=1+2+..+N


Информатика (38 баллов) | 32 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//Pascal
var N, i, F: integer;
begin
F := 0;
write('Введите N: '); readln(N);
for i := 1 to N do
  F := F + i;
write('F = ', F);
end. 

(9.4k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('F=',1.To(ReadInteger).Sum)
end.

Пример
318
F=50721
(150k баллов)