Помогите пожалуйста, нужно очень срочно. Надо написать программу ** PascalABCNET, которая...

0 голосов
48 просмотров

Помогите пожалуйста, нужно очень срочно. Надо написать программу на PascalABCNET, которая создаёт типизированный файл из 40 вещественных чисел. Расположенны они по такому принципу: первые 10- положительные, вторые 10- отрицательные, третьи 10- полижетельные, четвёртые 10- отрицательные (Пример: 1 2 3 4 5 6 7 8 9 10 -11 -12 -13 -14 -15 -16 -17 -18 -19 -20 21 22 23 24...) Нужно создать новый типизированный файл, в котором эти же числа будут расположены следующим образом: первые 5- положительные, вторые 5- отрицательные, третьи 5 - положительные и так далее.


Информатика (108 баллов) | 48 просмотров
0

Мне нужна именно помощь в том , как это выглядит в программе. Я не знаю, как написать сам код. Можете помочь?

0

Исходный файл записывается самим, числа берутся из головы.

0

Я не разбираюсь в теме типизированных файлов, поэтому и прошу помощи

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

Нулевой шаг: создание типизированного файла нужной структуры

begin
  var f:file of real;
  Assign(f,'MyReal.bin'); Rewrite(f);
  loop 2 do begin
    SeqRandomInteger(10,1,100).Select(t->t/10).ForEach(t->Write(f,t));
    SeqRandomInteger(10,-100,-1).Select(t->t/10).ForEach(t->Write(f,t));
    end;
  f.Seek(0); // начало файла
  var b:real;
  while not Eof(f) do begin Read(f,b); Print(b) end;
  Println;
  f.Close
end.

Пример:
9.7 1 4.1 8.3 5.6 9.3 2.2 9.3 5.8 8.8 -8.8 -7.7 -1.4 -5.2 -7.2 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 4.5 10 4.5 6.1 0.7 -8 -0.8 -3.3 -9.5 -7.9 -0.9 -7.4 -9.4 -1.8 -4.6

Собственно, программа

begin
  var f1,f2:file of real;
  Assign(f1,'MyReal.bin'); Reset(f1);
  if f1.FileSize mod 20<>0 then begin
    Writeln('Количество компонент во входном файле не кратно 20');
    Exit
    end;
  Assign(f2,'MyReal2.bin'); Rewrite(f2);
  var buf:=new real[5];
  var b:real;
  while not Eof(f1) do begin
    // переписываем пять положительных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // считываем пять положительных в буфер
    for var i:=0 to 4 do Read(f1,buf[i]);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // пишем пять положительных из буфера
    foreach var t in buf do Write(f2,t);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end
    end;
  f1.Close;
  // контрольное чтение 
  f2.Seek(0); // к началу 
  while not Eof(f2) do begin Read(f2,b); Print(b) end;
  Writeln; 
  f2.Close
end.

Пример
9.7 1 4.1 8.3 5.6 -8.8 -7.7 -1.4 -5.2 -7.2 9.3 2.2 9.3 5.8 8.8 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 -8 -0.8 -3.3 -9.5 -7.9 4.5 10 4.5 6.1 0.7 -0.9 -7.4 -9.4 -1.8 -4.6
(150k баллов)
0

Тогда объясните пожалуйста

0

Сейчас попробую. У меня что то вообще не грузит(