Помогите написать программу ** Паскале. В целочисленной матрице размером 10x10 найдите...

0 голосов
199 просмотров
Помогите написать программу на Паскале.

В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, равных ему.

Информатика (101 баллов) | 199 просмотров
Дан 1 ответ
0 голосов
var
ar: array[1..10,1..10] of integer;
i,j,max,count:integer;
begin
count:=1;
max:=0;
randomize;
for i:=1 to 10 do begin
for j:=1 to 10 do begin
ar[i,j]:=random(10)+1;
if (j mod 10=0) then writeln(ar[i,j]) else write(ar[i,j],' ');
if (ar[i,j] > max) then max:=ar[i,j];
end;
end;

for i:=1 to 10 do begin
for i:=1 to 10 do begin
for j:=1 to 10 do begin
if (ar[i,j] = max) then begin
writeln('Индекс ',count,' элемента = ',i,' ',j);
inc(count);
end;
end;
end;
end.
(558 баллов)
0

Чтобы не мучиться и не добавлять каждый элемент в массив, я сделал заполнение массива случайными числами, которые выводятся на экран.