Помогите написать программу для решения этой задачи ** паскале:"хватит ли N= 180 штук...

0 голосов
21 просмотров

Помогите написать программу для решения этой задачи на паскале:"хватит ли N= 180 штук кафельной плитки шириной A= 0,2 м шириной B=0,3 м для покрытия пола в помещении площадью S=12 м²?"


Информатика (15 баллов) | 21 просмотров
0

Плитка имеет размеры A*A или надо проверить 2 варианта 0,2*0,2 и 0,3*0,3?

0

A*B?

0

A*B

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,s:real; n:integer;
begin
n:=180;
s:=12;
a:=0.2;
write('Ширина ',a:3:1,' - ');
if a*a*n>=s then writeln('Yes')
else writeln('No');
b:=0.3;
write('Ширина ',b:3:1,' - ');
if b*b*n>=s then writeln('Yes')
else writeln('No');
end.

Результат:
Ширина 0.2 - No
Ширина 0.3 - Yes

(194k баллов)