С++. Напишите программу, которая выводит в одну строчку все делители переданного ей...

0 голосов
371 просмотров

С++. Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами. Делать через процедуру


Информатика (57 баллов) | 371 просмотров
Дано ответов: 2
0 голосов

12345678910111213141516171819202122Program task7; Var i : integer; procedure PrintAllDividers(n : integer; p : integer); Begin      if (p <= (n div 2)) then Begin        if (n mod p) = 0 then Begin            write(p);            write(' ');        end;        PrintAllDividers(n,p+1);      end;End; Begin      write('i=');      readln(i);      PrintAllDividers(i,1);      writeln;End.

(130 баллов)
0

что с сайтом?

0

1Program task7;

2Var i : integer;

3procedure PrintAllDividers(n : integer; p : integer);

4Begin
5 if (p <= (n div 2)) then Begin<br> 6 if (n mod p) = 0 then Begin
7 write(p);
8 write(' ');
9 end;
10 PrintAllDividers(n,p+1);
11 end;
12End;

13Begin
14 write('i=');
15 readln(i);
16 PrintAllDividers(i,1);
17 writeln;
18End.

0

ёмаё

0

1Program task7;
2
3Var i : integer;
4
5procedure PrintAllDividers(n : integer; p : integer);
6
7Begin
8 if (p <= (n div 2)) then Begin<br>9 if (n mod p) = 0 then Begin
10 write(p); write(' ');
9 end;
10 PrintAllDividers(n,p+1);
11 end;
12End;

13Begin
14 write('i=');
15 readln(i);
16 PrintAllDividers(i,1);
17 writeln;
18End.

0

короч я всё напутал

0

так в С++ же

0

а тут паскаль

0

Ох извини говорю же напутал

0 голосов

#include

using namespace std;

int main()
{
    int n;
    cin >> n;
    for (int i = 1; i <= n; ++i)<br>    {
        if (n % i == 0)
        {
            cout << i << " ";<br>        }
    }
}


(3.4k баллов)
0

пишет, что неверно