Нужно составить программу по блок-схеме!!!!)

0 голосов
18 просмотров

Нужно составить программу по блок-схеме!!!!)


image

Информатика (158 баллов) | 18 просмотров
Дан 1 ответ
0 голосов

Я тут решил попробовать вспомнить старое, но увы не получилось всё сделать правильно, вроде код ниже правильный, но где написано перед строкой "//" это я пометил, что не знаю как там писать. Попробуй сам изменить/дописать код:

program hello;
var
n, kd, d:integer;
begin
read(n);
kd:=0;
// d:=2...[sqrt(n)];
if n mod d = 0 then
kd:=kd+1
else
// d:=2...[sqrt(n)];
begin
if kd = 0 then
writeln('выв "простое"')
else
writeln('ыв "составное"')
end;
end.

(363 баллов)