Нужно написать программу в Pascal'е. Задание описано так. Требуется выделить из...

0 голосов
27 просмотров

Нужно написать программу в Pascal'е. Задание описано так. Требуется выделить из предложения четвертое слово (слова разделены пробелом).


Информатика (28 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

Var
  s: string;
  i: integer;
  qp: integer;
  word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
  if s[i]=' ' then
    qp:=qp+1
  else begin
     if qp=3 then word:=word+s[i];
  end;
  if qp=4 then
     break;
end;
if word='' then
  writeln('четвёртое слово не присутствует')
else
  writeln('искомое слово - ', word);

end.

{Пример}
На pascal написана соответствующая программа 
искомое слово - соответствующая

(17.3k баллов)