Надо написать программу в паскале225 А,226 Б,227 Ц,228 Д,229 Е,230 Ф,231 Г,232 Х,233...

0 голосов
61 просмотров

Надо написать программу в паскале
225 А,226 Б,227 Ц,228 Д,229 Е,230 Ф,231 Г,232 Х,233 И,234 Й,235 К,236 Л,237 М,238 Н,239 О,240 П,241 Я,242 Р,243 С,244 Т,245 У,246 Ж,247 В,248 Ь,249 Ы,250 З,251 Ш,252 Э,253 Щ,254 Ч,255 Ъ


image

Информатика (15 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var sk:=ReadAllText('koi8.txt');
  var a:=ReadlnString.ToWords;
  foreach var w in a do begin
    var p:=Pos(w,sk);
    if p>0 then begin
      p:=Pos(' ',sk,p+1);
      if p>0 then Write(sk[p+1]) else Write('?')
      end
    else Write('?')
    end;
  Writeln
end.

Пример
245 242 239 235
УРОК

Скачать вложение Текст (TXT)
(150k баллов)