Задания по программированию Решением задач 5–7 является программа, написанная ** одном из...

0 голосов
44 просмотров

Задания по программированию
Решением задач 5–7 является программа, написанная на одном из языков программирования.
Задачи 5–7 необязательно решать для получения полного балла.
Ограничение по времени работы программы в задачах 5–7: 1 секунда.
Решения задач 5–7 оцениваются, только если они выдают правильный ответ на всех
примерах входных и выходных данных, приведённых в условии задачи. Проверка решений
производится сразу же после отправки, по каждой задаче оценивается решение, набравшее
наибольшее число баллов. На странице «Итог» вы можете видеть окончательный балл по
всем задачам.
Программа не должна выводить никаких иных сообщений, кроме того, что требуется найти
в задаче. Во всех задачах целые числа во входных и выходных данных записываются только
цифрами (то есть недопустимо использование записи 1000000.0 или 1e6 вместо числа
1000000). Каждое число во входных данных записано в отдельной строке.
Задача 5. Спиннеры
Спиннер – модная игрушка c подшипником в основании, к которому прикреплены
лопасти. Афанасий открыл бизнес по производству спиннеров. Он выяснил, что за спиннер,
у которого N лопастей, покупатели готовы платить A + B × N рублей, но при этом покупатель
не станет покупать спиннер, если его цена будет выше C рублей. Определите максимальное
число лопастей спиннера, который согласится приобрести покупатель.
Программа получает на вход три числа A, B, C (стоимость основания спиннера,
стоимость одной лопасти и максимальная стоимость всего спиннера). Все числа – целые
положительные, не превосходящие 2×109 , при этом A ≤ C.
Программа должна вывести одно число – максимальное число лопастей спиннера.
Пример входных и выходных данных
Ввод Вывод Примечание
20
10
55
3 Спиннер с 3 лопастями будет стоить 50 рублей, а с 4 лопастями –
60 рублей. Максимальная возможная стоимость спиннера – 55
рублей, поэтому максимальное число лопастей равно 3.


Информатика (31 баллов) | 44 просмотров
Дано ответов: 2
0 голосов

Во вложеном файле приведено решение на  языке С++.
А вот на Pascal:

program Znanija;
var a, b, c, n: integer;
begin

read(a);
read(b);
read(c);
n:=(c-a) div b;
writeln();
writeln(n);

end.

(3.6k баллов)
0 голосов

Crf;bnt gj;fkeqcnf rfr cltkfnm 'ne pflfxe

(14 баллов)