Помогите составить программу в паскаль!!!!!

0 голосов
37 просмотров

Помогите составить программу в паскаль!!!!!


image

Информатика (41 баллов) | 37 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a:integer; s:string;
BEGIN
write('Введите число: ');
readln(a);
s:='';
while a>0 do
 begin
 if a mod 2=0 then s:='0'+s else s:='1'+s;
 a:=a div 2;
 end;
writeln(s);
END.

Пример:
Введите число: 131
10000011

(194k баллов)
0 голосов

Program num_sys;
Var n:integer;
  res:string;
begin
  readln(n);
  while n div 2 <> 0 do
  begin
    res:= res + n mod 2;
    n:= n div 2;
  end;
  res:= res + 1;
  write(res);
end.

(3.4k баллов)