Написать программу ** С Программа, которая переводит заданое число из восьмиричной...

0 голосов
43 просмотров

Написать программу на С
Программа, которая переводит заданое число из восьмиричной системы в пятиричную


Информатика (353 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Замечание: контроль правильности ввода не выполняется.
#include

int main(void) {
  int a_8, a_10, a_5, b, c;
  printf("Введите число в восьмеричной системе счисления: ");
  scanf("%d",&a_8);
  b = a_8;
  a_10 = 0; c = 1;
  while (b>0) {
    a_10 += c*(b % 10);
    c *= 8;
    b /= 10;
  }
  b = a_10;
  a_5 = 0; c = 1;
  while (b>0) {
    a_5 += c*(b % 5);
    c *= 10;
    b /= 5;
  }
  printf("%d(8) = %d(10) = %d(5)",a_8,a_10,a_5);
  return 0;
}

Пример:
Введите число в восьмеричной системе счисления: 2014
2014(8) = 1036(10) = 13121(5)

(194k баллов)