Напишите легкую программу ** Паскале пожалуйста. Напишите программу которая в...

0 голосов
72 просмотров

Напишите легкую программу на Паскале пожалуйста.
Напишите программу которая в последовательности нат. чисел определяет сумму чисел оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число оканчивающейся на 5. Количество чисел не превышает 100. Введённые числе по модулю не превышают 300. Программа должна вывести одно число: сумму чисел оканчивающихся на 5.
Входные данные 3 15 25 24
Выходные данные 40


Информатика (35 баллов) | 72 просмотров
Дан 1 ответ
0 голосов

Program suma;
Var a:array [1..100] of integer;
    k, i, sum:integer;
begin
  write('Введите число: ');
  read(k);
  for i:=1 to k do read(a[i]);
  for i:=1 to k do
    if a[i] mod 10 = 5 then
      sum:=sum + a[i];
 
  write('Сумма равна: ', sum);
end.

(3.4k баллов)