Напишите программу ** языке PascalABC.NET которая с помощью алгоритма Евклида вычисляет...

0 голосов
37 просмотров

Напишите программу на языке PascalABC.NET которая с помощью алгоритма Евклида вычисляет НОД.


Информатика (1.8k баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите через пробел два натуральных числа:');
  while b>0 do
    (a,b):=(b, a mod b);
  Writeln('НОД = ',a)
end.
(150k баллов)