Мария Александровна ведет занятия по информатике в школе № 27 г. Гомеля, начиная с 1 класса. Она хочет узнать, сколько учеников она обучает в N классах, если известно количество учеников в каждом классе. Она решила, что Вы сможете написать программу, которая узнает количество учеников в N классах. Решение в Паскаль АБЦ
Varn,a,b,i:integer;beginb:=0;writeln('введите количество классов');readln(n);for i:=1 to n do beginwriteln('введите количество учеников');readln(a);b:=a+b;end;writeln(b);end. Программа вроде работает,но писал на скорую руку,так,что проверь
Var n,a,b,i:integer; begin b:=0; writeln('введите количество классов'); readln(n); for i:=1 to n do begin writeln('введите количество учеников'); readln(a); b:=a+b; end; writeln(b); end.
Формат ввода:Пример ввода: N - кол-во классов (n<=30)<br>a[1] - кол-во учеников в первом классе a[2] - кол-во учеников во втором классе a[3] - кол-во учеников в третьем классе ... a[N] - количество учеников в N-ом классе3 10 15 20 Формат вывода: Пример вывода: k - количество учеников в N классах45
а с этим сможешь сделать?
К сожалению с массивами я бессилен(
и на этом спасибо)