Даю 18 баллов. Решите задачу по олимпиаде информатика 9 класс. Дан массив А размера N....

0 голосов
33 просмотров

Даю 18 баллов.
Решите задачу по олимпиаде информатика 9 класс.
Дан массив А размера N. Найти минимальный элемент из его элементов с четными номерами A2, A4, A6, ... .
Входные данные. Вводится одно натуральное число размер массива
Выходные данные. Выводятся одно число - минимальный элемент среди элементов с четными номерами (если несколько элементов имеют одинаковое значение вывести первый из них)

Пример ввода Пример вывода

1 2 5 6 8 2

0 5 1 3 9 8 3


Информатика (14 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

Ну я набросал на паскале :

program z;  var n,i,imax,s,p:integer;masiv:array of integer;begins:=0;p:=1;writeln('Кол-вол значений масива');read(n);setlength(masiv,n);  for i:=0 to n-1 do read(masiv[i]);  for i:=0 to n-1 do    begin      if i mod 2 = 0 then        if masiv[i]<imax then imax:=masiv[i];    end;  writeln();  write(imax,' ');  for i:=0 to n-1 do write(masiv[i],' ')end.

(367 баллов)
0

Залил на пастебин чтобы код был читаем -pastebin.com/AyU3UxS6

0

Могли бы вы решить это https://znanija.com/task/26612166

0

Пожалуйста