Помогите написать программу ** C++ ( двумя способами) Тема была циклы Нужно написать то...

0 голосов
25 просмотров

Помогите написать программу на C++ ( двумя способами)
Тема была циклы
Нужно написать то что во вложении с помощью двух циклов
1) c помощью цикла while
2) с помощью цикла do while


image

Информатика (5.5k баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//1) WHILE
#include
using namespace std;
int main() {
    double h = 4;
    double S = 0;
    double k = 5;
    while (k <= 51) {<br>        S = S + sqrt(k);
        k = k + h;
    }
    cout << "Sum = " << S << endl;<br>    system("pause");
    return 0;
}

//2) DO WHILE
#include
using namespace std;
int main() {
    double h = 4;
    double S = 0;
    double k = 5;
    do {
        S = S + sqrt(k);
        k = k + h;
    } while (k <= 51);<br>    cout << "Sum = " << S << endl;<br>    system("pause");
    return 0;
}

(9.4k баллов)