ДАЮ 30 БАЛЛОВ.РЕШИТЕ ЗАДАЧУ ПО ОЛИМПИАДЕ ПО ИНФОРМАТИКЕ!!! Решите задачу по олимпиаде...

0 голосов
46 просмотров

ДАЮ 30 БАЛЛОВ.РЕШИТЕ ЗАДАЧУ ПО ОЛИМПИАДЕ ПО ИНФОРМАТИКЕ!!!
Решите задачу по олимпиаде информатика 9 класс.
Дан массив А размера N. Найти минимальный элемент из его элементов с четными номерами A2, A4, A6, ..
Входные данные. Вводится одно натуральное число размер массива
Выходные данные. Выводятся одно число - минимальный элемент среди элементов с четными номерами (если несколько элементов имеют одинаковое значение вывести первый из них)
Пример ввода | Пример вывода
1 2 5 6 8 | 2
0 5 1 3 9 8 | 3


Информатика (97 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Ух уж олимпиадники, елементарную задачу решать не могут..
 Var n,i,k,min:integer;
a:array[1..1000] of integer;
Begin
 readln(n);
 for i:=1 to n do
  read(a[i]);
 min:=a[2];
 for i:=2 to n do
  if i mod 2=0
   then
    if a[i]     then min:=a[i];
 writeln(min);
End.

(5.8k баллов)