Задача по языку программирования Pascal n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1. Входные данные Программа получает на вход числа n и k. Выходные данные Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
если будет угодно, перепишите под свой, идею я подал и реализовал на PascalABC.NET
По которому не программируют уже +20 лет. Это задача из http://informatics.mccme.ru
Всё равно спасибо.
Ужас...ну формула подойдет под любой паскаль, которая k - (k div n) * n
да, я сейчас пытаюсь преобразовать скинутую мной формулу под то что вы мне дали)
Можно ли ещё вопрос?
var n,k,x:integer; begin readln(n,k); x:=k-n mod k; writeln('x=',x); end.
Совсем неправильно
Ни один тест не прошло...
хмм,..может потому, что там фаловый ввод вывод?