Написать программу, которая по заданной дате (числу d и месяцу m) определяет число дней,...

0 голосов
287 просмотров

Написать программу, которая по заданной дате (числу d и месяцу m) определяет число дней, прошедших от начала года, если известно, что год - не високосный.


Информатика (15 баллов) | 287 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const Months: Array [1..12] Of Integer = (31,28,31,30,31,30,31,31,30,31,30,31);
var d, m, result, i :integer;
Begin
  read(d, m);
  for i := 1 to m-1 do
    result := result + Months[i];

  writeln(result + d);
End.

(53.1k баллов)
0

если помогла то выбери решение лучшим, пожалуйста

0

спосибо