Помогите пожалуйста!!! Задача ** Paskal Напишите программу, которая вычесляет среднюю...

0 голосов
29 просмотров

Помогите пожалуйста!!! Задача на Paskal

Напишите программу, которая вычесляет среднюю температуру воздуха за 10 дней, выведит на экран max и min значение температуры. Данные вводятся с клавиатуры.


Информатика (18 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i,k: integer;
min,max: real;
begin
k:=0;
N:= 10;
for i:=1 to N do begin
read(a[i]);
k:=k+a[i];
end;
write('Вывод элементов массива: ');
for i:=1 to N do
write(a[i],' ');
min := a[1];
for i:=2 to N do
if a[i] begin
min := a[i];
end;
max := a[1];
for i:=2 to N do
if a[i]>max then
begin
max := a[i];
end;
writeln('max=',max,' ','min=', min,' ','Средная температура=',k/N)
end.

(120 баллов)