Написать программу ** паскале,которая проверяет,является ли введенная с клавиатуры строка...

0 голосов
64 просмотров

Написать программу на паскале,которая проверяет,является ли введенная с клавиатуры строка целым числом


Информатика (56 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите целое число:');
  var n:integer;
  if integer.TryParse(s,n) then Writeln('Корректно')
  else Writeln('Ошибка ввода')
end.
(150k баллов)