Пожалуйста помогите, надо сдавать работу ! Написать программу на языке С++ В заданном одномерном массиве поменять местами соседние элементы, стоящие на чётных местах, с элементами, стоящими на нечётных.
а если количество элементов - нечетное число? Что делать с последним?
при вводе сделаю четное количество элементов
#include #include using namespace std; int main(){ int n = 10; int arr[n]; for(int i = 0; i < n; ++i){ arr[i] = rand() % 300 - 150; cout << arr[i] << " ";<br>} cout << endl;<br>/*Начало важной части*/ for(int i = 0; i < n/2; ++i){ int buff = arr[2*i]; arr[2*i] = arr[2*i+1]; arr[2*i+1] = buff; } /*Конец важной части*/ cout << "Result: ";<br>for(int i = 0; i < n; ++i) cout << arr[i] << " ";<br>cout << endl;<br>system("pause"); return 0; }
error 'system' was not declared in this scope в 20 строке
где пишешь код?
codeblocks
пробуй
обе эти функции не особо важны
всё работает, спасибо
а нельзя значения самому ввести?
Можно. Но моя задача, дать тебе код, который меняет элементы местами.
Он отмечен как "важная часть"
Все остальное - мешура, чтобы показать, как работает код.