Составьте программу, которая формирует массив из 20 случайных чисел от -10 до 10выводит...

0 голосов
39 просмотров

Составьте программу, которая формирует массив из 20 случайных чисел от -10 до 10выводит на экрын элементы с нулевыми значениями и их индексами


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;

begin
N := 20;
for i:=1 to N do
a[i] := Random(20)-10;
writeln('Элементы массива: ');
for i:=1 to N do
write (a[i],' ');
writeln;
for i:=1 to N do
begin
if (a[i]=0) then
writeln(a[i],' ',i);
end;
end.

(120 баллов)