2/3+3/4+4/5...+10/11 Составить программу в паскале

0 голосов
44 просмотров

2/3+3/4+4/5...+10/11
Составить программу в паскале


Информатика (108 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

Вариант 1. Приблизительное решение.

begin
  Writeln('S=',2.To(10).Select(t->t/(t+1)).Sum)
end.

Результат
S=7.48012265512266

Вариант 2. Точное решение

uses NumLibABC;

begin
  var s:=Frc(0);
  for var i:=2 to 10 do s+=Frc(i,i+1);
  Writeln('Точное значение ',s,', приближенное ',s.ToReal)
end.

Результат
Точное значение 207349/27720, приближенное 7.48012265512266
(150k баллов)
0

а можно попроще, для 11 класса?