Написать программу С++ Составить программу вваода ** экран любого элемента массива из...

0 голосов
54 просмотров

Написать программу С++ Составить программу вваода на экран любого элемента массива из предыдущего заданияпо его индексу (пользователь вводит индекс с проверкой корректности в заданном интервале, на экран выводится элемент по индексу ,программа заканчивается,когда пользователь введёт -1


Информатика (819 баллов) | 54 просмотров
0

и в чем проблема?

Дан 1 ответ
0 голосов
Правильный ответ

//наконец то C++ а не паскаль, хотя я знаю их оба)

#include
using namespace std;

int main() {
int arr[10] {12, 45, 1, 4, 96, 71, 1, 9, 85, 3, 36}; /*ну как я понял элементы массива любые*/
int n;
while (n != -1) {
    if (n <= 10) {<br>        cin >> n;
        cout << arr[n] << endl;<br>    }
    else 
        cout << "Индекс выходит за пределы массива" >> endl;
}
return 0;
}

//как то так, писал прямо тут, могут быть ошибки

(312 баллов)
0

а почему не проверял?

0

блин я зачем то перед endl поставил >>, ну это объяснимо тем что писал ответ поздно, спать хотел