2. Написать программу, которая вводит массив из N целых чисел и выводит ** экранномера...

0 голосов
123 просмотров

2. Написать программу, которая вводит массив из N целых чисел и выводит на экранномера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов: а) 3,5,-2,0,-6,-8,1б) -1,-2,-3,-4,0,-1,2,3. Пожалуйста)))


Информатика (17 баллов) | 123 просмотров
0

я вообще щас на уроке

0

удачи тебе там)))

0

такой же и я)))

0

то что нужно? если нет, скажи что не так исправлю

0

спасибо, если что то я напишу)))

0

я написал так, что когда будешь вводишь числа в массив когда введёшь Y ты закончишь ввод

0

в принципе логичней было использовать цикл while для этого, но можно любой абсолютно

Дан 1 ответ
0 голосов
Правильный ответ

Var
mas:array[1..100] of real;
i:integer;
y:string;
Begin 
write('Вводите элементы массива, когда закончите введите Y: ');readln(y); 
for i:=1 to 100 do begin
if (y='Y') then i:=101
else         begin
mas[i]:=strTofloat(y);
readln(y); end;End;

for i:=1 to 100 do begin
if (mas[i]<0) then writeln('Номер элемента:',i,' Элемент:',mas[i]);end;<br>End.

(8.6k баллов)