Написать программу ** С++. Написать подпрограмму, которая находит максимальную цифру...

0 голосов
29 просмотров

Написать программу на С++. Написать подпрограмму, которая находит максимальную цифру заданного числа и выводит её на экран.


Информатика (819 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std; 

void mxd(int n) {
    int k,mx=0;
    do {
       k=n%10; n/=10;
       if (k>mx) mx=k;
    }
    while (n>0);   
    cout<<mx<<endl; <br>}    

int main() {   
    int n;
    cout<<"number: ";  cin>>n;
    mxd(n);
   system("pause");
    return 0;
}


(9.7k баллов)