Написать программу ** С++. Написать подпрограмму, которая принимает один аргумент и...

0 голосов
31 просмотров

Написать программу на С++. Написать подпрограмму, которая принимает один аргумент и выводит на экран факториал переданного ей числа.


Информатика (819 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std; 

void fac(int n) {
   int s=1;  
   for (int i=1; i<=n; i++) s*=i;<br>   cout<<s<<endl;<br>}    

int main() {   
    int n;
    cout<<"number: ";  cin>>n;
    fac(n);
   system("pause");
    return 0;
}


(9.7k баллов)