Помогите написать программу ** C++ Тема была Булева алгебра. Сначала нужно выяснить что...

0 голосов
44 просмотров

Помогите написать программу на C++
Тема была Булева алгебра.
Сначала нужно выяснить что будет в данном условии( Тру или фолс) и написать программу которая вычислит данное условие.
Во вложении.
PS В конце там меньше или равно 0


image

Информатика (5.5k баллов) | 44 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

(y>x*x) && b && (x*x*y*y>1)&&(y<7)&&(x>0.5)||(y*y<=0) ⇒<br>(-1>(-2)*(-2)) && true && ((-2)*(-2)*(-1)*(-1)>1)&&((-1)<7)&&((-2)>0.5)||((-1)*(-1)<=0) ⇒<br>(-1>4) && true && (4>1)&&(-1<7)&&(-2>0.5) || (1<=0) ⇒<br>false && true && true && true && false || false ⇒
false || false ⇒ false
#include
using namespace std;

int main() {
int x = -2, y = -1;
bool b = true, z;
z = (y>x*x) && b && (x*x*y*y>1)&&(y<7)&&(x>0.5)||(y*y<=0);<br> cout << "z = " << z;<br> return 0;
}

Результат:
z = 0

(194k баллов)
0 голосов

Альтернативная программа, результат тот же, что и у PetyaGavrikov
#include
using namespace std;
int main(){ 
 int x = -2; 
 int y = -1; 
 bool z = (y > x*x + 1 + x*x*y*y > 1 + y < 7 + x > 0.5 && y*y <= 0 ); <br> cout << z;<br>}

(8.8k баллов)