В ПАСКАЛЕ И ТОЛЬКО В ПАСКАЛЕ.1)дан массив десяти целых чисел напишите программу которая...

0 голосов
32 просмотров

В ПАСКАЛЕ И ТОЛЬКО В ПАСКАЛЕ.
1)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке не убывания.

2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок.
3)дан массив десяти целых чисел. Найти медиану числового ряда.
4) Дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 4
5) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.


Информатика (259 баллов) | 32 просмотров
0

2 задание бред..

Дан 1 ответ
0 голосов
Правильный ответ

 1) 
var i,n,k:integer;
 a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 for i:=10 downto 1 do
  write(a[i],' ');
 readln;
 readln
end.
3)
var i,n,k:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 writeln((a[5]+a[6])/2:0:2);
 readln;
 readln
end.
4)
var i,n,k,min:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 10=4) or (a[i] mod 10=-4)
    then min:=a[i];

 for i:=1 to 10 do
   if ((a[i] mod 10=4) or (a[i] mod 10=-4)) and (a[i]    then min:=a[i];
 writeln(min);
end.

5)
 var i,n,k,max:integer;
a:array[1..10] of integer;
begin
 max:=0;
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 5=0) and (a[i]>max)
    then max:=a[i];
  end;
 writeln(max);
end.

(5.8k баллов)
0

2-бред, 4-условие не понятно

0

оканчивающеесяя на 4

0

Щас добавлю