Напишите программу выводящую индекс наименьшего числа 3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81

0 голосов
40 просмотров

Напишите программу выводящую индекс наименьшего числа 3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81


Информатика (27 баллов) | 40 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=Arr(3,9,1,3,5,8,5,3,6,7,6,5,4,6,1,81); a.Println;
  a.IndexesOf(t->t=a.Min).Select(t->t+1).Println
end.

Результат
3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
3 15
(150k баллов)
0 голосов

var i,n,k,min:integer;
a:array[1..1000] of integer;
begin
 write('Write size array: '); readln(n);

 for i:=1 to n do
   read(a[i]);
 min:=a[1];
 for i:=1 to n do
  if min>a[i]
    then begin min:=a[i]; k:=i; end;
 writeln(k);
end.

(5.8k баллов)
0

program HelloWorld;
var
mas:array[1..14] of integer;
i,men:integer;
begin
randomize();
for i:=0 to 15 do begin
mas[i]:=random(10);
write(mas[i]:3);
end;
men:=mas[1];
for i:=2 to 15 do
if mas[i] < men then men:=mas[i];
writeln(men);
end.

0

Под это подставить сможете ?