Написать программу ** С (СИ) или ** другом языке

0 голосов
29 просмотров

Написать программу на С (СИ) или на другом языке


image

Информатика (978 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
#include
 
int main(void) {
int n=1;
int a2 = 2, a3 = 3;
double eps = 0.003;
double an = 1.0/a2+1.0/a3;
double s = an;
while (an>eps) {
  a2 *= 2; a3 *= 3;
  an = 1.0/a2+1.0/a3;
  s += an;
}
printf("s = %lf\n", s);
return 0;
}

Результат:
s = 1.498021
(194k баллов)
0

что означает "double" тут?

0

double - вещественный тип двойной точности

0

а это . не для С++, для С тоже подходит?

0

подходит

0

int n=1; можно убрать