Напишите программу в паскалье

0 голосов
30 просмотров

Напишите программу в паскалье


image

Информатика (15 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a: array [1..10] of integer;
kp,i: integer;
mul: real;
begin
kp:=0;
mul:=1;
for i:=1 to 10 do
begin
a[i]:=-3+random(7);
write(a[i],' ');
if a[i]>0 then begin
kp:=kp+1;
mul:=mul*a[i];
end;
end;
writeln;
write('произведение положительных: ',mul,'; количество положительных: ',kp);
end.

(149k баллов)