Помогите пожалуйста написать программу ** ABC Pascal :Дан двумерный массив А, состоящий...

0 голосов
40 просмотров

Помогите пожалуйста написать программу на ABC Pascal :
Дан двумерный массив А, состоящий из N элементов. Найти минимальный из элементов этого массива с нечетными индексами и максимальный из элементов с четными индексами.
На фото что-то написал, но выдает ошибку
P.S. : Я чайник в этом))


image

Информатика (146 баллов) | 40 просмотров
0

ну напиши через ABC.NET, если это возможно

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var (p,q):=a.Partition((v,i)->i.IsOdd);
  Writeln('min=',p.Min,', max=',q.Max)
end.

Пример
n= 13
-2 39 24 32 -25 32 -41 35 47 -49 20 20 41
min=-49, max=47

Замечание: В PascalABC.NET, как и большинстве других современных языков, индексы начинаются от нуля. Если хочется думать, что индексы - это порядковые номера элементов (т.е. первый элемент массива имеет "индекс" 1, а не 0, в программе нужно заменить контекст Odd на Even.
(150k баллов)