Написать программу в PascalABC.net Удалить из строчки S символы + - * А потом заменить...

0 голосов
54 просмотров

Написать программу в PascalABC.net
Удалить из строчки S символы + - *
А потом заменить все символы на символы следующие по алфавиту.


Информатика (20 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  s:=s.RegexReplace('[\+\-\*]',''); // удалили
  s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
  Writeln(s)
end.

Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
(150k баллов)