Помогите пожалуйста написать программу ** паскале. Найти корень уровнения...

0 голосов
45 просмотров

Помогите пожалуйста написать программу на паскале.
Найти корень уровнения
F(x)=ln⁡(x)-(0.5/x^2)=0
в интервале [ 0.1 ; 1.5 ]
x=1,327_864


Информатика (35 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

uses NumLibABC;

begin
  var oL:=new Zeroin(x->Ln(x)-(0.5/Sqr(x)),1e-8);
  Writeln('x=',oL.Value(0.1,1.5):0:8)
end.

Пример с точностью 10⁻⁸
x=1.32786401

Замечание: Исходный текст класса Zeroin в составе библиотеки численных методов NumLibABC находится в стандартной поставке PascalABC.NET
(150k баллов)
0

В том то и дело, мне надо именно на самом обычном паскале, мой препод не знает про обновленные версии ничего... :с