Нужна помощь с информатикой. 35 баллов. 1. Определите значение переменной S после...

0 голосов
33 просмотров

Нужна помощь с информатикой. 35 баллов.
1. Определите значение переменной S после выполнения алгоритма:
x:=340
y:=5
x:=x div y
y:=x mod y
x:=x-5
y:=y+3
s:=x+y
2. Определите значение переменной а после выполнения данного алгоритма.
a:=3
b:= -1
b:=9+a*b
a:= (b*b)/(b/a)
Все обязательно в таблицах. Заранее спасибо.


Информатика (56 баллов) | 33 просмотров
0

что значит в таблицах?

0

Секунду.

0

То есть колонка для ответов с иксом или а.

0

не понимаю тебя, давай просто скину код программы?

0

Ладно.

0

Мне бы подробный ответ.

0

там код программы как-бы...

0

Мы по-другому решаем. В виде таблицы.

0

напиши в лс

0

Окей

Дан 1 ответ
0 голосов
Правильный ответ

1)
var x,y,S:integer;
begin
x:=340;
y:=5;
x:=x div y;
y:=x mod y;
x:=x-5;
y:=y+3;
S:=x+y;
writeln(S);
end.
Ответ получился 69
2) var a, b:real;
begin
a:=3;
b:=-1;
b:=9+a*b;
a:=(b*b)/(b/a);
writeln(a);
end.
Ответ получился 18