Помогите пожалуйста сделать задание по программированию в Pascal. 1. Найти произведение...

0 голосов
44 просмотров

Помогите пожалуйста сделать задание по программированию в Pascal.
1. Найти произведение всех элементов массива размерностью N (если элемент равен 0, то пропустить).
2. Найти максимальный по модулю элемент матрицы. Напечатать его значение и индексы.


Информатика (15 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
const
  N = 5;//Размерность массива

var
  m: array[1..N] of integer;

begin
  var pr := 1;
  for var i := 1 to N do
  begin
    read(m[i]);
    if m[i] <> 0 then pr := pr * m[i];
  end;
  writeln(pr);
end.

Пример:
Входные данные:
1 2 3 0 5
Выходные данные:
30

2)
const
  N = 3;//Размерность матрицы

var
  m: array[1..N, 1..N] of integer;
  i, j: integer;
  rec: record
    mmax: integer = -(maxint);
    ind: record
      i: integer;
      j: integer;
    end;
  end;

begin
  for i := 1 to N do
    for j := 1 to N do
    begin
      read(m[i, j]);
      if abs(m[i, j]) > rec.mmax then begin
        rec.mmax := abs(m[i, j]);
        rec.ind.i := i;
        rec.ind.j := j;
      end;
    end;
  writeln('Максимальный по модулю элемент матрицы ', rec.mmax, '(', rec.ind.i, ';', rec.ind.j, ')');
end.

Пример:
Входные данные:
1 2 3
4 5 -9
7 8 6
Выходные данные:
Максимальный по модулю элемент матрицы 9(2;3)

(720 баллов)
0

При команде выполнить просит ввести данные.Какие данные?

0

То, что надо. Первая программа просит ввести элементы массива размерностью N (или ввести N элементов). Вторая программа просит ввести элементы матрицы размерностью NxN (в примере, 3 на 3).

0

Ввел но при попытке вывести результат на экран просто ничего нет.

0

Простите, что у Вас по информатике?) На код хорошенько посмотрите, не может ничего не быть.