Помогите написать программу ** pascal Вычислить сумму квадратов вводимых чисел. числа...

0 голосов
25 просмотров

Помогите написать программу на pascal

Вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.


Информатика (20 баллов) | 25 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.

Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
(150k баллов)
0 голосов

//PascalABC.NET
//Версия 3.3, сборка 1611 
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.

(149k баллов)
0

не работает

0

У вас устаревшая версия PascalABC

0

Скачайте новую